Cara Update IP Publik Mikrotik dengan changeip – Adakalanya kita kesulitan untuk memantau mikrotik kita dari luar area jaringan. Jika pada saat era koneksi adsl kita dapat membuat dialup langsung dari mikrotik sehingga mikrotik kita dapat langsung terkoneksi melalui ip publik, dan dapat kita deteksi ip publiknya secara langsung melalui interfacenya dan dapat kita buatkan scriptnya dengan mengirim data interface tersebut ke server dns dinamis ataupun ke email kita.
Namun saat ini jaringan Fiber Optik sudah banyak digunakan. Beberapa problem yang sering ditemui adalah kita kesulitan mensetting dialup langsung dari mikrotik dikarenakan harus mac address mikrotik kita harus diintegrasikan dengan sistem isp yang kita gunakan. Sehingga hal ini membutuhkan waktu dan kordinasi antara admin jaringan dengan isp yang bersangkutan. Belum lagi jika kordinasi antara CS ISP dan TS ISP yang agak lama membuat kita malas untuk menggunakan dialup langsung dari mikrotik pada jaringan Fiber Optik. Update IP Publik Mikrotik dengan changeip.
Satu-satunya cara yang dapat kita terapkan dengan simple dan dapat kita kerjakan langsung tanpa kordinasi dengan isp adalah dengan port forwarding pada modem gpon. namun kesulitan kita adalah memantau ip publik yang dinamis, sehingga kita butuh bantuan pada orang yang sedang dalam jaringan tersebut untuk memberitahu ip address publik pada jaringan tersebut.
Berikut Teknew SeloBeCity memberikan tips untuk memantau perubahan ip publik yang dinamis tersebut dengan memanfaatkan changeip.com:

  1. Pertama silahkan anda daftar pada changeip, jika anda sudah mempunyai akun di changeip anda cukup login di changeip
  2. Kemudian silahkan anda buat free dnshost pada dns manager, isikan dnshost anda pada kolom “add free domain“.
  3. Jika free domain anda sudah terbuat, anda buat script di mikrotik dengan script di bawah ini:
    # Dynamic DNS Update / Simple Edition
    :global ddnsuser "CHANGEIP_USER"
    :global ddnspass "CHANGEIP_PASS"
    :global ddnshost "CHANGEIP_HOST"
    :global ddnsip
    :local resolvedIP [:resolve $ddnshost]
    /tool fetch url="http://myip.dnsomatic.com/" mode=http dst-path=ipaddress.txt
    :set ddnsip [/file get [/file find name=ipaddress.txt] contents]
    :log info "set ddnsip: $ddnsip"
    :if ([ :typeof $ddnsip ] = "nothing" ) do={
        :log info ("DDNS: tidak ada ip yang terset pada ddnsip $ddnsip, silahkan cek kembali")
    } else={
      :if ($ddnsip != $resolvedIP) do={
        :log info "DDNS: mengirimkan update ip $ddnsip ke changeip.com!"
        :log info [ :put [/tool dns-update name=$ddnshost address=$ddnsip key-name=$ddnsuser key=$ddnspass ] ]
      } else={
        :log info "DDNS: ip saat ini $ddnsip sama dengan ip sebelumnya $resolvedIP"
      }
    }

    Sesuaikan parameter user, pass dan host (domain) sesuai dengan data yang anda buat pada changip. Update IP Publik Mikrotik dengan changeip.

  4. coba jalankan script dan pantau pada log mikrotik anda, jika berhasil maka akan muncul keterangan:
    DDNS: mengirimkan update ip xxx.xxx.xxx.xxx ke changeip.com
  5. Semoga sukses

 

Note: setelah saya cek, script ini dapat berjalan pada vers 6.x keatas.

 

Tinggalkan Balasan

Alamat email Anda tidak akan dipublikasikan. Ruas yang wajib ditandai *